本文へジャンプします。

ニフティクラウド ユーザーガイド

クラウド トップ>ユーザーガイド>コンピューティング>VPNゲートウェイ:IKEv1 IPsec VPN(L3VPN)で接続する拠点側VPN装置の設定(FITELnet F60/F200/F2200)

VPNゲートウェイ:IKEv1 IPsec VPN(L3VPN)で接続する拠点側VPN装置の設定(FITELnet F60/F200/F2200)

VPNゲートウェイを利用し、ニフティクラウドとお客様拠点をIPsec VPN(L3VPN)で接続するためには、以下の項目を事前にご確認ください。以降の設定手順、確認手順では下記を検証環境、構成例として用います。

下記ページと構成を参考に、事前にVPNコネクション作成を行ってください。

構成

VPNゲートウェイを利用し、ニフティクラウドとお客様拠点をIPsec VPN(L3VPN)で接続するためには、以下の項目を事前にご確認ください。 以降の設定手順、確認手順では下記を検証環境、構成例として用います。

検証環境
製品 FITELnet F60/F200/F2200
ソフトウエア F60: V01.11(00)
F200: V01.17(00)
F2200: V01.03(00)
  • ※最新ファームへのバージョンアップを推奨
構成例
PPPoEユーザー名 user@ispA
PPPoEパスワード isppasswdA
VPNゲートウェイのIPアドレス 198.51.100.1
拠点VPN装置のIPアドレス 203.0.113.1
プライベートLAN CIDR 172.16.1.0/24
拠点CIDR 192.168.1.0/24
共有鍵 SECRET

設定手順

設定モードに移行します。

  • ※工場出荷状態からの設定を行う場合はclear working.cfgコマンドを実行し、初期設定を削除しておきます。
Router#clear working.cfg
WARNING: Another users has already edited working.cfg.
  Please check working.cfg.
clear ok?[y/N]:yes

Router#configure terminal
Router(config)#

PPPoEインターフェースの設定を行います。

  • ※「user@ispA」は実際のPPPoEユーザー名に、「isppasswdA」は実際のPPPoEパスワードにそれぞれ置き換えてください。
Router(config)#interface pppoe 1
Router(config-if pppoe 1)#ip address 203.0.113.1
Router(config-if pppoe 1)#pppoe server PPPOE_SVR
Router(config-if pppoe 1)#pppoe account user@ispA isppasswdA
Router(config-if pppoe 1)#pppoe type lan
Router(config-if pppoe 1)#exit

LANインターフェース関連の設定を行います。

Router(config)#interface lan 1
Router(config-if lan 1)#ip address 192.168.1.254 255.255.255.0
Router(config-if lan 1)#exit
Router(config)#service dhcp-server
Router(config)#ip dhcp pool lan 1
Router(config-dhcp-pool)#dns-server 0.0.0.0
Router(config-dhcp-pool)#default-router 0.0.0.0
Router(config-dhcp-pool)#allocate-address 192.168.1.1 100
Router(config-dhcp-pool)#lease 0 8
Router(config-dhcp-pool)#exit
Router(config)#proxydns mode v4

IPsec機能を有効にし、VPN通信動作中のログを残す設定を行います。

Router(config)#vpn enable
Router(config)#vpnlog enable

IKEポリシーに関する設定(暗号アルゴリズム、ハッシュ・アルゴリズム、事前共有鍵など)を行います。

  • ※「198.51.100.123」は実際のVPNゲートウェイのIPアドレスに、「SECRET」は実際の共有鍵にそれぞれ置き換えてください。
Router(config)#crypto isakmp policy 1
Router(config-isakmp)#authentication prekey
Router(config-isakmp)#encryption aes 128
Router(config-isakmp)#group 2
Router(config-isakmp)#hash sha
Router(config-isakmp)#keepalive always-send
Router(config-isakmp)#key ascii SECRET
Router(config-isakmp)#lifetime 28800
Router(config-isakmp)#negotiation-mode main
Router(config-isakmp)#peer-identity address 198.51.100.1
Router(config-isakmp)#exit

DPDのパラメータを設定します。

Router(config)#crypto security-association
Router(config-crypto-sa)#ikealive freq 15
Router(config-crypto-sa)#ikealive retry max 5
Router(config-crypto-sa)#ikealive retry timer 15
Router(config-crypto-sa)#exit

ESPのSAのポリシーとして、暗号化アルゴリズム、認証アルゴリズムの設定を行います。

Router(config)#ipsec transform-set P2-POLICY esp-aes-128 esp-sha-hmac

IPsecのセレクタ情報を設定します。

Router(config)#ipsec access-list 1 ipsec ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
Router(config)#ipsec access-list 64 bypass ip any any

crypto mapに関する設定を行います。

  • ※「198.51.100.1」は実際のVPNゲートウェイのIPアドレスに置き換えてください。
Router(config)#crypto map CENTER 1
Router(config-crypto-map)#match address 1
Router(config-crypto-map)#set peer address 198.51.100.1
Router(config-crypto-map)#set pfs group2
Router(config-crypto-map)#set security-association lifetime seconds 3600
Router(config-crypto-map)#set transform-set P2-POLICY
Router(config-crypto-map)#exit

IPsecインターフェースとcrypto mapの結び付けを行います。MTUとMSSの設定を行います。

Router(config)#interface ipsecif 1
Router(config-if ipsecif 1)#crypto map CENTER
Router(config-if ipsecif 1)#ip mtu 1500
Router(config-if ipsecif 1)#exit
Router(config)#mss lan 1 1300
Router(config)#mss ipsecif 1 1300

Static経路の設定を行います。

NATを利用する場合

NAT関連の設定を行います。

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Router(config)#access-list 150 permit esp host 203.0.113.1 host 198.51.100.1
Router(config)#access-list 160 permit esp host 198.51.100.1 host 203.0.113.1
Router(config)#access-list 190 dynamic permit ip any any
Router(config)#access-list 199 deny ip any any
Router(config)#interface pppoe 1
Router(config-if pppoe 1)#ip nat inside source list 1 interface
Router(config-if pppoe 1)#ip access-group 150 out
Router(config-if pppoe 1)#ip access-group 160 in
Router(config-if pppoe 1)#ip access-group 190 out
Router(config-if pppoe 1)#ip access-group 199 in
Router(config-if pppoe 1)#exit

デフォルト経路とプライベートLAN CIDR宛の経路設定を行います。

Router(config)#ip route 0.0.0.0 0.0.0.0 pppoe 1
Router(config)#ip route 172.16.1.0 255.255.255.0 connected ipsecif 1
NATを利用しない場合

VPNゲートウェイ宛の経路とプライベートLAN CIDR宛の経路設定を行います。

  • ※「198.51.100.1」は実際のVPNゲートウェイのIPアドレスに置き換えてください。
Router(config)#ip route 198.51.100.1 255.255.255.255 pppoe 1
Router(config)#ip route 172.16.1.0 255.255.255.0 connected ipsecif 1

設定を終了、保存、bootコンフィグに設定し、装置を再起動します。

Router(config)#end
Router#save SIDE-A.cfg
% saving working-config
% finished saving

Router#boot configuration SIDE-A.cfg
Router#reset
Going to reset with SIDE-A.frm and SIDE-A.cfg.
Boot-back not scheduled for next boot.
Next rebooting firmware SIDE-A.frm is fine.
Are you OK to cold start?(y/n)y

確認手順

拠点側からプライベートLAN宛にPingによる疎通確認をする
kyoten_host:˜$ ping 172.16.1.1
PING 172.16.1.1 (172.16.1.1) 56(84) bytes of data.
64 bytes from 172.16.1.1: icmp_req=1 ttl=62 time=7.29 ms
64 bytes from 172.16.1.1: icmp_req=2 ttl=62 time=10.1 ms
64 bytes from 172.16.1.1: icmp_req=3 ttl=62 time=8.95 ms
IKEのSAが正常に確立されているか確認する

show crypto isakmp saコマンドを実行します。
Current値において、IKE のSAが確立してからの経過時間が表示されていれば正常に確立できています。

Router#show crypto isakmp sa
ISAKMP SA
current sa : 1

[ 1] 198.52.100.1
    <--> 203.0.113.1
  <I> Main Mode UP pre-shared key AES(128bits) SHA
  Lifetime : 28800secs
  Current : 100secs,1kbytes
  mcfg config-mode: off
  mcfg addr: off
  mcfg apl-version:
  IKE Keepalive: dpd
  ICMP Keepalive: off
  release on addr-change: off

Router#
ESPのSAが正常に確立されているか確認する

show crypto ipsec saコマンドを実行します。
Current値において、ESPのSAが確立してからの経過時間が表示されていれば正常に確立できています。

Router#show crypto ipsec sa
IPSEC SA
  current insa : 1
  current outsa : 1

[ 7] 172.16.1.0,255.255.255.0 ALL ALL
    <--> 192.168.1.0,255.255.255.0 ALL ALL
  peer: 198.52.100.1 ipsecif: 1
  local: 203.0.113.1

  <I> UP Tunnel ESP AES(128bits) HMAC-SHA PFS:on(group2)
  Lifetime: 3600secs
  Anti-Replay: Enable
  O-SPI: 0xcfb57134 Current: 98secs,15kbytes
    out packet : 97 error packet : 0
  I-SPI: 0x5f96af58 Current: 98secs,15kbytes
    in packet : 97 auth packet : 97
    decrypt packet : 97 discard packet : 0
    replay packet : 0 auth error packet : 0

Router#

ニフティクラウド サイト内検索

ユーザーガイドメニュー

  • ツイッターでフォローしてください
  • ニフティクラウド公式フェイスブックページ

推奨画面サイズ 1024×768 以上