本文へジャンプします。

ニフクラ ユーザーガイド

クラウド トップ>ユーザーガイド>コンピューティング>VPNゲートウェイ:IKEv1 L2TPv3/IPsec VPN(L2VPN)で接続する拠点側VPN装置の設定(Cisco IOS)

VPNゲートウェイ:IKEv1 L2TPv3/IPsec VPN(L2VPN)で接続する拠点側VPN装置の設定(Cisco IOS)

拠点側VPN装置にCisco IOSを使用した場合の設定です。

下記ページと構成を参考に、事前にVPNコネクション作成を行ってください。
ヘルプ:VPNゲートウェイ:作成

構成

VPNゲートウェイを利用し、ニフクラとお客様拠点をL2TPv3/IPsec VPN接続するためには、以下の項目を事前にご確認ください。 以降の設定手順、確認手順では下記を検証環境、構成例として用います。

検証環境
ソフトウエア IOS 15.1以上
構成例
VPNゲートウェイのIPアドレス 198.51.100.123
拠点VPN装置のIPアドレス 203.0.113.234
共有鍵 0582877a-3907-4357-8763-d32e9050eb08

設定手順

※事前に、GigabitEthernet0をWAN側に、FastEthernet8をLAN側に接続してください。

  1. コンソールにログインし、グローバル・コンフィギュレーション・モードに移行します。

    #configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    (config)#
  2. IPsecの設定を行います。

    (config)#ip access-list extended acl_vpn_niftycloud
    (config-ext-nacl)#permit ip host 203.0.113.234 host 198.51.100.123
    (config-ext-nacl)#exit
    (config)#crypto isakmp policy 1
    (config-isakmp)#encryption aes 
    (config-isakmp)#hash sha 
    (config-isakmp)#authentication pre-share
    (config-isakmp)#group 2
    (config-isakmp)#lifetime 28800
    (config-isakmp)#exit
    (config)#crypto isakmp key 0582877a-3907-4357-8763-d32e9050eb08 address 198.51.100.123
    (config)#crypto isakmp keepalive 15 periodic
    (config)#crypto ipsec transform-set niftycloudset esp-aes esp-sha-hmac
    (cfg-crypto-trans)#mode transport
    (cfg-crypto-trans)#exit
    (config)#crypto map niftycloudmap 1 ipsec-isakmp
    % NOTE: This new crypto map will remain disabled until a peer
            and a valid access list have been configured.
    (config-crypto-map)#set peer 198.51.100.123
    (config-crypto-map)#set security-association lifetime seconds 3600 
    (config-crypto-map)#set transform-set niftycloudset
    (config-crypto-map)#match address acl_vpn_niftycloud
    (config-crypto-map)#exit
    (config)#interface GigabitEthernet0
    (config-if)#crypto map niftycloudmap
    (config-if)#
    Jul  1 04:08:35.567: %CRYPTO-6-ISAKMP_ON_OFF: ISAKMP is ON
    (config-if)#exit
    (config)#
  3. L2TPv3の設定を行います。

    ※今回の例では、自分自身と相手のセッションIDをともに1としています。「l2tp id 1 1」を実際のセッションIDの値に置き換えてください。

    (config)#pseudowire-class niftycloudl2tpv3
    (config-pw-class)#encapsulation l2tpv3
    (config-pw-class)#interworking ethernet
    (config-pw-class)#protocol none
    (config-pw-class)#ip local interface GigabitEthernet0
    (config-pw-class)#exit
    (config)#interface FastEthernet8
    (config-if)#xconnect 198.51.100.123 1 encapsulation l2tpv3 manual pw-class niftycloudl2tpv3
    (config-if-xconn)#l2tp id 1 1
    (config-if-xconn)#l2tp cookie local 4 0
    (config-if-xconn)#l2tp cookie remote 4 0
    (config-if-xconn)#exit
    (config-if)#no shutdown
    (config-if)#exit
    (config)#
    Jul  1 04:11:20.643: %LINK-3-UPDOWN: Interface FastEthernet8, changed state to up
    Jul  1 04:11:21.643: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet8, changed state to up
    (config)#exit
    #
  4. 設定を保存します。

    #write memory
    Building configuration...
    [OK]
    #

確認手順

show l2tp sessionコマンドで接続状態を確認します。

#show l2tp session

L2TP Session Information Total tunnels 0 sessions 1

LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID
                                 Vcid, Circuit
1          1          n/a        1, Fa8               est    00:38:37 2
#

ニフティクラウド サイト内検索

ユーザーガイドメニュー

  • ツイッターでフォローしてください
  • ニフクラ公式フェイスブックページ

推奨画面サイズ 1024×768 以上