本文へジャンプします。

ニフクラ APIリファレンス

nifty-replace-vpn-gateway-latest-version

処理概要

API「NiftyReplaceVpnGatewayLatestVersion」が実行されます。
指定したVPNゲートウェイを最新バージョンに入れ替えます。
入替前のVPNゲートウェイは、バックアップとして一定期間保持されます。
VPNゲートウェイを指定するためには、VPNゲートウェイユニークIDまたはVPNゲートウェイ名が必要です。処理中のVPNゲートウェイを指定した、管理外のVPNゲートウェイを指定した、既に最新バージョンのVPNゲートウェイを指定したなど、無効なVPNゲートウェイを指定した場合は、エラーが返されます。

VPNゲートウェイが既にバックアップを保持している場合は、オプション「--agreement」を指定し、バックアップを解除する必要があります。バックアップを保持しているかどうかはAPI「DescribeVpnGateways」のレスポンス値「isBackup」で確認できます。

コマンド構文

nifty-replace-vpn-gateway-latest-version [オプション]

オプション

オプション 短縮 説明 必須
--vpn-gateway-id ID -g VPNゲートウェイユニークIDを指定します。
(VPNゲートウェイ名といずれか)
--vpn-gateway-name NAME -G VPNゲートウェイ名を指定します。
(VPNゲートウェイユニークIDといずれか)
--agreement   version up実施したのち、バックアップ状態を解除する事項への同意を指定します。
(バックアップを保持する場合のみ)

出力要素

※ニフクラAPIの応答フィールド名を記述します。

  • VPNGATEWAY / vpnGatewayId or vpnGatewayName

実行サンプル

PROMPT>nifty-replace-vpn-gateway-latest-version -g vgw-8db04f81 --agreement
VPNGATEWAY vgw-8db04f81

ニフティクラウド サイト内検索

APIメニュー

  • ツイッターでフォローしてください
  • ニフクラ公式フェイスブックページ

推奨画面サイズ 1024×768 以上