本文へジャンプします。

ニフティクラウド APIリファレンス

nifty-update-security-group-option

処理概要

  • ※APIバージョン1.11以降ではご利用いただけません。

API「UpdateSecurityGroupOption」が実行されます。
ファイアウォールのオプション情報を更新します。

利用コースに2を指定した場合、有償版への変更に際する注意事項が表示されます。
更新後ファイアウォール数上限を指定する場合、ファイアウォールの有償版に申し込んでいない場合は、エラーが返されます。

コマンド構文

nifty-update-security-group-option [オプション]

オプション

オプション 短縮 説明 必須
--cource 更新後の利用コース -c 更新後の利用コースを利用するかを指定します。(1:無償、2:有償)  
--group-limit-update 更新後のファイアウォールグループ数の上限 -g 更新後のファイアウォールグループ数の上限を指定します。  

出力要素

※ニフティクラウドAPIの応答フィールド名を記述します。

  • GROUP_OPTION / 属性名(指定したパラメーターによって異なります)
  • GROUP_OPTION / value

実行サンプル

PROMPT>nifty-update-security-group-option --course 2
  ファイアウォール有償版では…
  注意事項に同意しますか?[Ny]
  y
注意事項に同意しました。
GROUP_OPTION course 2

ニフティクラウド サイト内検索

APIメニュー

  • ツイッターでフォローしてください
  • ニフティクラウド公式フェイスブックページ

推奨画面サイズ 1024×768 以上